I suggest you ...

Finding changesets / reviews by name with wildcards (where like '%...')

Please, add the possibility to use queries like this:
find changesets where branch like 'release%' (to find changesets from branches release1, release2, releaseB,...) or this: find reviews where title like '%fail%' and so on.

This feature is already available for changeset->comment, but not for changeset->branch or review->title.

37 votes
Vote
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
You have left! (?) (thinking…)
JakubH shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

4 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • AdminCodice Software (CEO / Founder, plasticscm) commented  ·   ·  Flag as inappropriate

    Hi JakubH,

    There's a fundamental issue with the cm find branch where name like 'release%'.

    It works provided that the name of the branch (the actual name, nor its parents) matches the query.

    Look at my command:

    >cm find "branch where name like 'Release-%' and date >= '1 months ago'"
    7616825 7/1/2016 11:01:19 /main/Release-5.4.16.761 jesusmg codice T
    7621981 7/5/2016 14:14:38 /main/Release-5.4.16.762 jesusmg codice T
    7626620 7/7/2016 10:58:08 /main/Release-5.4.16.763 jesusmg codice T
    7632847 7/11/2016 12:52:16 /Fix-5.0/Release-5.0.44.764 jesusmg codice T
    7639164 7/15/2016 09:58:21 /main/Release-5.4.16.765 jesusmg codice T
    7643011 7/21/2016 10:03:46 /main/Release-5.4.16.766 jesusmg codice T

    Total: 6

    BUT, if you expect to search on the "parents" names, then it won't work. It doesn't because the query is run just on the branch name, nor its parents, because the branches just store their names, while parents are built looking up in the tree, so there's no easy way to SQL-it in a portable way.

    In case of "changeset->branch" different happens. "cm find changeset where branch=" only allows "=" because the branch is resolved on the client side, and the id of the branch sent to the server. We do not allow multi-value entries there, I'm afraid.

    So, your request actually affects 2 very different objects: branch hierarchy on one hand, and a way to solve specs on the other.

    We never forgotten this, but we weren't unable to tackle it so far.

    Hope this helps.

  • JakubH commented  ·   ·  Flag as inappropriate

    Hm, it is working for review->title now (on 5.0.44.629). I don't remember if there was any problem in the past. However, it still doesn't work for the referenced branch: "find changesets where branch like 'release%'", which is the main issue for us.

  • AdminCodice Software (CEO / Founder, plasticscm) commented  ·   ·  Flag as inappropriate

    For reviews it always worked. Look:

    C:\Users\pablo\wkspaces\four\01nerva\build\client>bcm find reviews where title like '%for%'
    1653304 11/15/2012 10:40:54 ruben Status0 pablo "Review for SCM11714" Branch id:1628828
    1654020 12/12/2012 10:31:06 ruben Status0 violeta "Review for SCM12064" Branch id:1653990
    1756476 4/1/2013 10:08:49 ruben Status0 borja "Review for SCM12389" Branch id:1746241
    1757256 4/3/2013 16:08:51 ruben Status0 borja "Review for SCM12448" Branch id:1746263
    1781018 7/17/2013 14:46:50 ruben Status0 borja "Review for SCM12876" Branch id:1780995

  • psantosl commented  ·   ·  Flag as inappropriate

    Ok, you know you can do it for branches like this: cm find branch where name like '%task%'

    But yes, when we introduce a 'reference' (like the branch in the csets query), then it is slightly different... We'll see what we can do

Feedback and Knowledge Base